Author Topic: Can it ever run right?  (Read 2307 times)

0 Members and 1 Guest are viewing this topic.

Bodaddio

  • n00balicious
  • Posts: 7
Can it ever run right?
« on: January 25, 2008, 10:12:59 PM »
Hey guys.  I have a question and appreciate all the help you guys always give.
So I have a 99 1.8 Passat with almost 180,000 on it.
A couple of months ago I had a misfire on #3. Got a new ICM and ran pretty good.  Also changed the plugs and COPs at the same time.
Then the Coolant temp sensor went out.  Got that done, (stay away from Osborne!)
Things were good then started running like crap and got a CEL.  Checked it out, it was the MAF.  Fixed that ran good for a little bit.
Now the trouble, when it gets warmed up and running for a little bit, it will run like crap.  It will act like it isn't getting any gas.  When I get to a light and stop it will start to idle all erratic, and when you go it will just creep along.  Then all of a sudden it will take off.  It will drive good for a minute or two then start to sputter again.  Next light the same thing.  Erratic idle and I mean all over the place, down below 500 then shoot up to about 1200 then back down. 
Anyone have an idea?  There is no CEL and it only does it when it is warm.  I am about at wits end with this car.  Any advice is appreciated.

Thanks,
Shawn

masterqi

  • Lightly Modded
  • **
  • Posts: 124
Re: Can it ever run right?
« Reply #1 on: January 26, 2008, 03:09:12 AM »
(stay away from Osborne!)


See, all the dealerships *are* crap! :P

Rocky Mountain Club B5

Re: Can it ever run right?
« Reply #1 on: January 26, 2008, 03:09:12 AM »

dubaudi

  • Lightly Modded
  • **
  • Posts: 134
Re: Can it ever run right?
« Reply #2 on: January 26, 2008, 03:56:27 AM »
My A4 did the same thing. I changed the fuel filter and it hasnt done it since.
92 MkII GTI
00 Audi A4 1.8T
90 G60 Corrado

Bodaddio

  • n00balicious
  • Posts: 7
Re: Can it ever run right?
« Reply #3 on: January 26, 2008, 01:39:36 PM »
Yeah, I have a blue coolant temp sensor, they gave me a green one and when I told them it was blue, he said it changed and it will work just fine.  Took it to Emich and they just changed it out for the blue and and laughed.
Fuel filter, I will give that a shot.  Oh yeah forgot to mention I changed the 02 sensor out also.
Thanks,
Shawn

jfrahm

  • Modded
  • ***
  • Posts: 693
Re: Can it ever run right?
« Reply #4 on: January 26, 2008, 02:29:59 PM »
Fuel filter might be it.  Since you recently changed the MAF I'd also look hard at the intake plumbing.  A loose clamp or crack letting in unmetered air will cause a similar condition.

-Joel.
2001 Audi A8 Quattro 4.2l

Bodaddio

  • n00balicious
  • Posts: 7
Changing fuel filter
« Reply #5 on: January 26, 2008, 10:52:14 PM »
OK I changed out the fuel filter.  Would you guys reset the computer after?  Still crapping out at idle.

Thanks,
Shawn

Chas

  • Modded
  • ***
  • Posts: 633
Re: Can it ever run right?
« Reply #6 on: January 27, 2008, 05:37:10 PM »
Do you have access to a VAG-COM? Chck out the O2 sensors.

Unfortunately you have hit all the major bits that go bad on the AEB engined Passats. The good news is that once they are all changed it should be running fine. The other thing is that you have a ton of miles on that car. 180K is quite a lot. When was the last time the timing belt was changed? They should be changed at around 60K miles per belt. It should be on it's 3rd belt at this point.
But do check out those O2 sensors. Pop in at an AutoZone and have them run their diagnostic tool and see what that says.

Good luck!
2003 Audi A6 2.7T
Some Sedans haul families,
this one hauls ASS!

jayryan

  • Supercar
  • *****
  • Posts: 6,211
    • JayFriesen.com
Re: Can it ever run right?
« Reply #7 on: January 27, 2008, 11:05:18 PM »
I'm sure there's someone on the board with a VAG if you need one too. I'm in Montana so I wouldn't be very helpful there ::)
'03 A4 1.8TQM
'68 MG C
'06 4Runner

SweetVW

  • Heavily Modded
  • ****
  • Posts: 1,677
Re: Can it ever run right?
« Reply #8 on: January 27, 2008, 11:16:58 PM »
I have a VAG that can be used.  I live in the SW side of town, by Wadsworth & Quincy.  Let me know if that will work for you.
If it ain't broke, take it apart and fix it!