Author Topic: blowing smoke, loosing coolant, throwing codes  (Read 1351 times)

0 Members and 1 Guest are viewing this topic.

bret

  • Stock
  • *
  • Posts: 41
blowing smoke, loosing coolant, throwing codes
« on: May 08, 2009, 02:16:52 PM »
i posted on AW with a couple responses but thought i'd see what the locals think:


i've got a 2001 with ~114k miles, original turbos. i've only owned the car for just over a month but am already having some serious problems.

i had the car looked at by what i thought was a reputable shop and had the all clear before i bought it but have since discovered i have some serious repairs coming up. i've replaced the diverter valves and the throttle body boot as well as addressed a couple boost leaks. I also found that the bank 2 turbo was "wet" and i had oil up on the driver's side of the throttle body boot. After draining the intercoolers i have since been manually turbo timing the car for at least a minute.

The car still smokes at idle and the smoke never goes away. i just took the car on a road trip about 700 miles away and while i was driving around my family driving behind me mentioned that i had puffs of smoke coming from the tail pipes (they couldn't comment on timing).

On the trip my oil level light would come on every couple hours, if i pulled over and checked the oil(which was never low) the light would go away for a short time. During one stretch of having the oil light on my red oil light and CEL came on so i pulled over, checked everything and aside from burning a very small amount of oil everything else seemed normal. i also had to top the coolant from min to max twice in my 1400 mile trip. i got the car to the shop when i got back.

They replaced the oil level sensor and pulled the following codes:
Code: [Select]
Code:
17867 P1459 163
Sensor 2 for exhaust temperature -G236
implausible signal [sporadic]

16538 P0154 163
O2 Sensor Circuit, Bank2 - Sensor1
No Activity Detected [sporadic]

16815 P0431 163
Warm Up Catalyst, Bank 2
Efficiency Below Threshold [sporadic]

When i went to pick up the car i started the car and sat and chatted with the owner for a little while(~10 minutes) and when i went to my car i noticed the smoke at idle had increased dramatically.

As i pulled away i was blowing more smoke than i've ever seen come out of a car. My wife came to drop me off and she was driving behind me but there was enough blue/white smoke that i couldn't even see her. She said the smoke didn't actually go away until we got to speed on the highway but also that it came back after a few miles (but not in ridiculous amounts, just sporadic).

The next morning the car smoked at idle like normal and with my wife driving behind me for a about a mile she said it didn't really smoke at all. As i got a couple miles down the road (she turned off to go to work) and got onto the highway i had a biker behind me and i noticed as i got onto the onramp the car started to smoke again. By the time i got on the highway (at partial throttle) i had enough smoke behind me to completely blind the unfortunate biker. The car smoked pretty much until i got into work.

i decided to go out during lunch and see if i could get this smoke on camera with a co-worker but ended up only getting a small but noticeable amount of smoke but only between shifts off throttle.

After work as i was driving through traffic the car started smoking a lot more off throttle and decelerating and finally my red oil light came on. i pulled to the shoulder, shut it off, turned the key back to ready, hit the self diagnose button which said "OK". i started it up, got back into rush hour traffic and got the shop on the phone - they told me if the red light comes on again it would be safer to tow it. And as they said it the light came on so i pulled over and had the car towed.

The car isn't loosing power or making any screeching turbo noises. So i'm wondering:

1) any ideas on the smoke? turbos? HG? head problems? block problems?
2) any ideas on the disappearing coolant? found one small leak but nothing to explain the constant top offs.

Sorry for the long post :P

thanks
bret

PS here's the video gietl took of my car at lunch:
http://www.youtube.com/watch?v=xuZlMbpXT98

Noob_Shum

  • Modded
  • ***
  • Posts: 782
Re: blowing smoke, loosing coolant, throwing codes
« Reply #1 on: May 08, 2009, 02:57:56 PM »
I had a bad gasket with a cracked head on one of my old cars, and the smoke was much more dramatic than what you have.... That said, I think if you have a bad gasket, or maybe a cracked head, you could get coolant loss as well as smoke in the exhaust. Is there a weird milky looking gunk in the oil when you check it? I am by no means a mechanic, but that is what I have experienced in the past. Good luck, hope you can get it fixed soon!

Jonathan

Rocky Mountain Club B5

Re: blowing smoke, loosing coolant, throwing codes
« Reply #1 on: May 08, 2009, 02:57:56 PM »

bret

  • Stock
  • *
  • Posts: 41
Re: blowing smoke, loosing coolant, throwing codes
« Reply #2 on: May 08, 2009, 03:11:16 PM »
Thanks Jonathan - i would imagine that if i had a bad HG or a cracked head that i would get thick white smoke all the time and not so sporadically? i have no idea though. The smoke in the video is probably the least amount it's smoked and i have no idea why/how. Since that morning it was 5x worse, at idle it's a just a continuous small amount and on the way home that day it was at least twice as bad but by no means huge walls of smoke.

the smoke does not have that distinct coolant smell though... definitely oil.

the dip stick looks normal to me but the filler cap has some odd gunky residue on it..

Oh and on AW i posted in the b5 s4 forums so i didn't specify the model, but there you have it. 2001 s4.

here's what the idle smoke looked like before i went on my trip:
http://www.youtube.com/watch?v=-luUhuykobE

ianacole

  • Heavily Modded
  • ****
  • Posts: 2,622
    • http://www.rmsolo.org
Re: blowing smoke, loosing coolant, throwing codes
« Reply #3 on: May 08, 2009, 04:13:35 PM »
Have you done a compression test?
"The corruption of man is followed by corruption of language." -Emerson

Think you're fast? http://www.rmsolo.org

For the road racer in all of us: http://www.nasarockymountain.com

bret

  • Stock
  • *
  • Posts: 41
Re: blowing smoke, loosing coolant, throwing codes
« Reply #4 on: May 08, 2009, 04:16:03 PM »
not yet... but good idea

gragravar

  • Supercar
  • *****
  • Posts: 4,315
Re: blowing smoke, loosing coolant, throwing codes
« Reply #5 on: May 08, 2009, 04:50:11 PM »
leaking that much coolant, my bet is a leaky head gasket.  I'd continue to guess that all that coolant and oil burning is fouling your o2 sensors and cats and thus the codes you are seeing.

Any man who can drive safely while kissing a pretty girl is simply not giving the kiss the attention it deserves.  ~Albert Einstein

bret

  • Stock
  • *
  • Posts: 41
Re: blowing smoke, loosing coolant, throwing codes
« Reply #6 on: May 08, 2009, 04:57:04 PM »
at this point i can't decide which is worse.. HG or turbos? if i'm lucky it'll be both!